Iphone Stuck in Emergency Call Screen after 3.0 upgrade, Power Button not working

Discussion in 'iPhone Discussion & Support' started by lowell3, Jul 14, 2009.

  1. lowell3

    lowell3 New Member

    Joined:
    Jul 14, 2009
    Messages:
    1

    I really need some help i will try my best to describe this problem i am having with my 2g 8gig iphone.

    1. Updated my iphone to firmware 3.0 via itunes and from that point the power button does not seem to work, when pressing i hear the clicking sound but the slide to power off does not come up.

    2. I tried restoring and it goes as far as when the logo of the usb and itunes comes up and I am able to restore firmare back to 3.0 but unable to downgrade to any other firmware as i keep getting erroe 20 when i try (firmware 2.0 etc)

    3. I tried letting the battery drain completely and recharging but nothing happens, tried all the information about placing in recovery mode and nothing works, seems impossible to put in Dfu mode because the power button does not seem to be working at all so i keep getting errors and i also tried this Dfu software that you install to the root of your hard drive and still no luck.

    At this point all the iphone does is go into emergency call mode and recovery mode and other times it just basically keeps restarting and displaying the apple logo.

    Any help is appreciated i just want to know if i should just call it quits because the iphone is beyond repair, or if there is any hope at all
     
  2. blue frog

    blue frog Well-Known Member

    Joined:
    Jun 28, 2008
    Messages:
    291
    Location:
    Colorado

    Similar Problem

    Hi,

    I have a 2G 16GB iPhone and I got a message stating that I need to RESTORE my iPhone. I connected to iTunes and placed my iPhone into the dock and waited for it to be recognized. Instead, a message came on telling me that my Sim chip is not correctly connected and that I need to take it out and reinsert it. I did so and got the same message.

    So, I set an appointment for the Genius Bar at my local Apple Retail Store. When the Genius checked, he found the same problem(s). He then went through the process to get me a replacement iPhone. HOWEVER, the Genius told me that my 1st Generation 2G 16GB iPhone is "under constraint" and that it will take as long as 2 weeks to get a replacement iPhone shipped to the store. He took down my landline phone number, so that I can be called when it comes in; then I can come in and get the replacement iPhone.

    MEANWHILE, the Genius suggested that I go to my local AT&T store and get a replacement for my Sim chip. When I got to the AT&T store, it took me about 30 seconds to get the old Sim chip replaced with a new one. The AT&T rep told me that when I got home, that I should go through the process of setting up my iPhone as a new phone (Go through the questions such as: What is your phone number?, etc.). Unfortunately, I was not able to get even that far since, when I placed my iPhone into the dock and waited for it to be recognized, I got the same message as before telling me that I have a problem with my Sim chip and that I need to take it out and reseat it.

    Thus, I have a non-functioning 2G 16GB iPhone and a 2 week wait for any meaningful solution.

    Oh yeah, the Genius said that I could just get a cheap "Go Phone" from AT&T while I am waiting for that replacement iPhone.

    I got a followup email from Apple asking me how my appointment at their Genius Bar went. I shared all of the above info; we'll see if they connect with me and try to produce a better solution.

    For your situation, I strongly suggest that you set up an appointment at your local Apple Retail Store. Otherwise, you have a brick on your hands and no solution.
     
  3. optimusprime

    optimusprime Well-Known Member

    Joined:
    Jul 19, 2009
    Messages:
    167

    hi iowell,
    your problem is very much solvable....the error 20 is what u will always get when the baseband(modem firmware version) does not match with the firmware version...so its quite natural and do not try to downgrade to 2.x.x just yet...
    i will post details steps soon and u follow it exactly as it is....
    do tell me if u r able to get to the recovery mode screen...i .e itunes with the cable on it?