O2 UK Icon Disappeared

Discussion in 'iPhone Discussion & Support' started by notlongnow, Apr 26, 2009.

  1. notlongnow

    notlongnow New Member

    Joined:
    Apr 26, 2009
    Messages:
    1

    Hi

    This is my first time on the forums I've never needed to use them b4 now. Thing is ive had my Iphone 3G payg FOR bout 5 weeks and i absolutely love it, dont know what i did without one.

    Thing is i travelled to work in my car the other day and for some reason the phone roamed onto a different telecommunication system than my normal O2-UK network. It logged onto a system that comes from the Isle of man i live along the coast in cumbria not too far from the isle of man but ever since that particular part of the journey i have had the O2-UK network Icon from the top Left Hand Side corner next to the signal strength bars dissapear. I have reset the phone twice once of my own back, secondly from advice from O2. I even called apple support and they have never heard anything like it happen before.

    My text and credit keeps on going down as normal and the phone works as normal but i find it a bit disconcerting that the icon should be there and it isn't.
    Also when you go into settings and then into about it says under service provider: unknown

    Has any one heard of this icon disapearing with any of your phones because even though the phone works fine i would like the icon back.

    Sorry for the long windedness of the post but if you need a biit more info please feel free to post back and i will try and give you more info.
    Thanks for your time and help in anticipation

    Lee J Hill
     
  2. samin

    samin New Member

    Joined:
    Apr 27, 2009
    Messages:
    2

    Help Require

    I had run reset all settings from Iphone 2G, after that i can’t deduct
    my iphone and even i can't deduct on Itune for software update. I hold a restart key for more than 6 second and i can see just Apple logo only.
    Can some one please tell me how to recover software on my iphone? or some one please help me...
     
  3. talltomtomson

    talltomtomson New Member

    Joined:
    May 10, 2009
    Messages:
    1

    Same Problem :(

    Hey,
    I returned back from a weekend in the Isle of Man today and my O2-UK symbol has disappeared as well. I have tried resetting the Phone, Resetting the Network Setting, and removing and returning my SIM card. None of these worked.

    The Phone works fine, 3G, Edge, Wi-Fi, Cellular Data Connection, All absolutely fine.

    It is a bit frustrating but i think it must be something to do with the network connection in the Isle of Man which was "Manx Telecom Mobile"

    Any Ideas and Solutions would be hugely appreciated

    Cheers
     
  4. LittleTed

    LittleTed New Member

    Joined:
    Aug 20, 2009
    Messages:
    1

    I also have the exact same symptoms - however it started when I was in the Lake District going high up over Hardknott Pass!! I received a data roaming SMS and the logo disappeared. Since the Isle of Man isn't very far away from there I'm assuming I picked up a stray Manx Telecom signal.

    I reset the network settings, restored the phone and got a new SIM from O2. Also the problem occured just as the upgrade to OS 3.0 came along but the upgrade didn't cure the problem either.

    It's probably not a general roaming problem since I have used the iPhone in Eire lots of times before and it displayed the O2.ie logo whilst I was there and reverted to the O2 logo when I returned to the UK.

    I've given up worrying about it as the iPhone works and I didn't clock up any roaming charges (O2 were helpful in checking this).